Pytanie:
Cyberduck zamiennik dla transferów SCP
Jeroen Wiert Pluimers
2014-04-03 01:57:12 UTC
view on stackexchange narkive permalink

Ponieważ Cyberduck używa Javy, to dla mnie nie ma znaczenia.

Jakikolwiek zamiennik Mavericks, który jest dobry, ma podobną funkcjonalność do WinSCP i ma opcję wypróbowania przed zakupem?

Tylko dlatego, że używa Java? Co jest nie tak z Javą? Ponadto, jeśli wyszukujesz w Google „mac ftp”, powinieneś znaleźć całkiem sporo.
Nie chcę FTP. Chcę SCP. Ostatni CyberDuck, którego próbowałem użyć, chciał mieć zbyt starą wersję Javy (której Apple już nawet nie dostarcza) i nie mam wystarczającej pewności, że Oracle wie, jak aktualizować Javę na Macu (prawie nie can w systemie Windows). Wbudowana Java jest po wyjęciu z pudełka: zbyt duże zagrożenie bezpieczeństwa.
Zgaduję, że scp w terminalu też nie działa?
@dwightk Używam scp w linii poleceń teraz na SuSE i Mac OS, ESXi i Windows poprzez Cygwin, ale często jest to zbyt niezdarne. Obecnie prowadzę śledztwo w sprawie [Midnight Commander with SCP support] (http://wiki.blue-panel.com/index.php/Midnight_Commander_ (en) #SCP_Client :). BTW: Dzięki za edycję.
Doszedłem do wniosku, że po tym, jak trzy razy mówisz ludziom, że nie chcesz ftp, to była dobra korekta: D
Tak. ftp. czy zrobiłeś to w poprzednim życiu, kiedy można było zaufać sieci. Używam SSH od połowy lat 90. ubiegłego wieku (:
Czy próbowałeś użyć okna dialogowego Finder's Go> Connect to Server z ssh: //?
Tak: `adresy URL typu„ ssh: ”nie są obsługiwane.`.
Jak myślisz, dlaczego Java stanowi tutaj zagrożenie dla bezpieczeństwa? Java w przeglądarce tak, ale Java do aplikacji? Nie jest znacznie bardziej ryzykowne niż Cel C.
@patrix idź powiedz, że do miejsc, w których pracuję (: Idealnie chcę narzędzie, które korzysta z plików binarnych OpenSSL i może być scrunitized.
Hmm: istnieją "najnowsze" uniwersalne pliki binarne "mc" dla Mac OS X na http://louise.hu/poet/tag/mc/ są one teraz w 4.8.10, podczas gdy obecna wersja dla wielu platform to 4.8.12 http://www.midnight-commander.org/wiki
Siedem odpowiedzi:
#1
+6
Édouard
2014-04-03 02:58:23 UTC
view on stackexchange narkive permalink

Słyszałem tylko dobre rzeczy o Transmitowaniu

Polecam też Transmit.
Witryna mówi tylko o ftp i sftp. Czy to też robi SCP?
@JeroenWiertPluimers może łączyć się z serwerami FTP, SFTP, Amazon S3 i WebDAV.
Ponieważ nie robi SCP, to też jest na zewnątrz (zobacz tag SCP w moim pytaniu: jest to dla mnie obowiązkowe).
nie robi SCP .. Interarchia, jak wspomina Edouard, jest najlepszym narzędziem do SCP pod OS X, jak sądzę.
@dwightk SFTP jest rozszerzeniem SCP, nawet jeśli nie jest technicznie obsługiwany przez twój serwer, spróbuj go mimo wszystko.To może zadziałać.Mój tak.
TRANSMIT NIE OBSŁUGUJE SCP (tylko SFTP) i kosztuje 45 $!Dodaj to do swojej odpowiedzi.
#2
+4
Édouard
2014-04-04 05:22:43 UTC
view on stackexchange narkive permalink

Interarchy to klient FTP, który udostępnia wiele innych protokołów, w tym SCP i SFTP.

Spróbuję tego. Dzieki za sugestie.
o tak, używałem ich dawno temu, kiedy pojawił się OSX, ale z jakiegoś powodu przełączyłem się na Transmit. Dobrze wiedzieć, że robią SCP
#3
+4
Jeroen Wiert Pluimers
2015-09-03 17:08:04 UTC
view on stackexchange narkive permalink

Przerzuciłem się na Filezillę, która działa świetnie zarówno na Macu, jak i Windowsie. https://filezilla-project.org

To było po tym, jak dowiedziałem się, że klient Filezilla Mac OS X obsługuje SFTP na tych samych serwerach, które również wykonują SCP.

(uwaga dla siebie: SFTP nie jest inną formą FTP , to bardziej przypomina lepszy SCP)

Po ponad roku używania Filezilli, nigdy nie wróciłbym do Cyberducka.

#4
+3
user3061675
2015-09-03 13:53:36 UTC
view on stackexchange narkive permalink

Cyberduck nie obsługuje SCP (już). Zobacz zamknięty bilet: bilet 8895. Wypróbuj DCommander dla SCP na Macu.

#5
  0
dwightk
2014-04-04 01:08:42 UTC
view on stackexchange narkive permalink

Wygląda na to, że Fugu wykonuje scp, a nawet zdobył nagrodę Apple Design Award za najlepsze wykorzystanie oprogramowania open source (w 2003 r.).

Edytuj:”

Wadą: jest to aplikacja PPC, więc nie działa, chyba że nadal używasz Snow Leopard.

Fugu nie było rozwijane zbyt długo, ale dla ludzi, którzy chcą spróbować: Istnieje prawie 3-letnia wersja fugu 1.2.1pre1 beta, która działa na platformie Intel pod adresem http://sourceforge.net/projects/fugussh/ akta/
#6
  0
user3864879
2014-07-23 12:13:48 UTC
view on stackexchange narkive permalink

Mogę potwierdzić, że cyberduck działa dobrze również w Yosemite.

Używając Javy pobranej ze strony Oracle.

Cyberduck CZY używa SCP, ja regularnie go używam.

Wydaje się, że na prostej witrynie PFTP (port 21) pojawiają się problemy z przekroczeniem limitu czasu.

dzięki za aktualizację, ale ponieważ używa Java, nadal jest dla mnie niedostępny.
Używam cyberducka 4.7.1 i nie widzę opcji dla SCP (poluję również na klienta Mac SCP i jak dotąd Interarchy wydaje się być jedyną reklamą).
#7
-1
David Kocher
2014-04-04 00:39:40 UTC
view on stackexchange narkive permalink

Cyberduck 4.4 lub nowszy nie wymaga instalacji oprogramowania Java.

Otrzymuję mieszane wyniki, gdy próbuję dowiedzieć się, na czym opiera się osadzony czas wykonywania. Jeśli jest to Java, to też jest wykluczone: minimalizacja wektorów ataków tutaj.
https://trac.cyberduck.io/browser/tags/release-4-4-3/lib/1.7.0-u40-b30.jre/Contents/Home/release
@mtm wielkie dzięki. Tak więc używana przez nich wersja Javy to 1.7.0-u40-b30.jre sprzed co najmniej 9 miesięcy.
W osadzonym środowisku wykonawczym nie ma „wektora ataku”.


To pytanie i odpowiedź zostało automatycznie przetłumaczone z języka angielskiego.Oryginalna treść jest dostępna na stackexchange, za co dziękujemy za licencję cc by-sa 3.0, w ramach której jest rozpowszechniana.
Loading...